Goodbye qtranslate, welcome to mqtranslate

Share

qtranslate_barreQtranslate have not evolved for around 1 year, which is a compatibility problem with latest versions of WordPress. I prevented myself to update to wordpress 4.x until an hypothetic update of qtranslate. Nothing to gain here, qtranslate author is no more supporting it, it’s going to stay at version 2.5.39.

mqtranslateGood news, several actions have started and new extensions, based on this old qtranslate, appeared : qtranslate plus, qtranslate-x, mqtranslate, … I myself have selected mqtranslate plugin which have more regular updates. This evolution would seem to be complicated and risky. In the contrary it has been simple and without any problem.

You can find information about mqtranslate on this web page : http://www.xhaleera.com/wordpress/mqtranslate/

Migration is done in 7 steps :

  1. Installation of mqtranslate plugin using WordPress Plugins menu

    Take care not to activate mqtranslate at this step

  2. Deactivation of qtranslate plugin with same menu
  3. Then activate mqtranslate
  4. Import qtranslate plugin parameters into mqtranslate. For that :

    – access to configuration page of mqtranslatemqtranslate configuration– display advanced parameters and use option to migrate qtranslate configuration to mqtranslate

    – Confirm parameters change

    At this moment, language parameters you were using in qtranslate should be identical into mqtranslate

  5. Reconfigure default language of wordpress if necessary, using configuration page of mqtranslate
  6. Include language selector widget from mqtranslate at same place than the one you were using from qtranslate
  7. After a full check of your website, you can now imagine to de-install qtranslate plugin, but it sounds a good idea to keep it installed but deactivated

Here it is, transfer is done. Website behaviour shouldn’t have changed although visual appearance

After it is done, it’s now possible to update wordpress to V4.0 or V4.1, thanks to mqtranslate being already compatible to those versions  🙂

Share

Vincent Recipon

Propriétaire de ce blog. Owner of this blog.

You may also like...

6 Responses

  1. Noaneo says:

    Bonjour,Je suis en train d’aider une personne et celle ci voudrait traduire son site en anglais et peut être en Allemand, n’ayant jamais fait ça, je voulais savoir le plugin que vous proposez est compatible WP4.3.1 et si c’est celui utilisé sur votre site? J’espère que j’aurai une réponse, c’est assez urgent, pardon.
    Merci

    • Bonjour,
      Qtranslate n’est plus a utiliser. Je l’ai remplacé par mqtranslate, mais celle-ci n’est plus supporté depuis quelques mois.
      C’est à présent l’extension qtranslate-X que j’utilise sur ce site. Cette extension est compatible avec les extensions précédemment citées et son fonctionnement est proche.
      QTRANSLATE-X est compatible avec les dernières versions de WordPress (4.3.1 ici). C’est donc un bon choix, il faut juste espérer que son support continuera !

    • Noaneo says:

      Bonjour,
      Merci de m’avoir répondu si vite,
      Juste une petite question, pourquoi, je vois le site en anglais, il ne se met pas en français automatiquement pour les visiteurs de France ou frnacophone?
      Merci
      Bonne journée

    • Noaneo says:

      Autant pour moi, j’ai vérifié mon lien dans mon marque-pages, il avait le lien vers la version anglaise, donc cela est ma faute, excusez moi.

  2. darknote says:

    Bonjour,
    c’est le plugin utilisé sur votre site?
    Je ne le trouve pas sur les plugins de WordPress, j’ai trouvé à la place
    https://wordpress.org/plugins/qtranslate-x/
    mais est-il bien ?
    Merci

Leave a Reply

Your email address will not be published. Required fields are marked *